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ECP PASSTHRU OVERVIEW
CellCom and DualCom Universal Communicators enable you to take over and manage ECP panels with 
connection to the ECP Bus. This feature is called ECP Passthru. 

This guide is designed to walk you through ECP passthru installation and setup. For more complete 
information, refer to the CellCom Installation Guide (LT-1817) or the DualCom Installation Guide (LT-1859).

Procedure
The installation must follow this procedure:

Step 1: Mount the communicator.

Step 2: Wire the communicator.

Step 3: Program Vista keypad device address 20

Step 4: Configure ECP settings (remotely or locally)

Required Materials
The following software and hardware components are required to perform system takeovers:

• Compatible Honeywell VISTA panel (refer to “VISTA Panel Compatibility”)
• CellCom or DualCom with minimum firmware Version 202
• (Optional) Programming keypad with Model 330 or Model 330-24V programming cable
• (Optional) Cat 5 Ethernet cable
• 18-22 AWG unshielded wire (RYGB)
• Remote Link minimum Version 2.02
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Figure 1: CellCom and DualCom Components

https://buy.dmp.com/dmp/products/documents/LT-1817.pdf
https://buy.dmp.com/dmp/products/documents/LT-1859.pdf
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STEP 1: MOUNT THE COMMUNICATOR
It is not necessary to remove the PCB from the housing when installing the communicator. 

The communicator should be mounted to a wall using the included #6 screws in the mounting holes. Refer 
to Figure 1 for mounting hole locations. 

Mount the communicator in a secure, dry place to protect it from tampering and weather damage. If using a 
685 Series Conduit Backbox, refer to the 685 Installation Sheet (LT-1431) for mounting instructions.

STEP 2: WIRE THE COMMUNICATOR
The communicator can be connected to the ECP Bus of a VISTA panel. See Table 1 and Figure 2 for the 
necessary wiring connections.

 Caution: Remove all AC and battery power from the panels before wiring. 

1. Attach the antenna to the SMA connector. Refer to Figure 1. 

2. Connect system batteries as needed, then connect the panels to an appropriate power source. 

3. Connect a programming keypad to the communicator.

a. For 12 VDC applications, connect the keypad to the communicator PROG header with a Model 330 
programming harness. 

b. For 24 VDC applications, connect the keypad to the communicator PROG header with a 
Model 330-24V programming harness with an in-line resistor. 

4. After programming is complete, remove the keypad and replace the housing cover on the mounted base. 

 Note: Address 1 is reserved by the system for programming keypads. 

https://buy.dmp.com/dmp/products/documents/LT-1431.pdf
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Figure 2: ECP Wiring

Communicator to ECP Wiring
Com Series ECP Bus Typical Color

+DC Keypad Power Red

-DC Keypad GND Black

Z4+ Data Out Yellow

Z4- Data In Green

Table 1: Wire Connections
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STEP 3: PROGRAM THE VISTA KEYPAD
Program Vista Keypad Device Address 20

In this step, you will program VISTA Keypad 5 Device Address 20. This enables the VISTA panel to 
communicate with a CellCom or DualCom. This step must be performed locally at the VISTA panel.

1. Power down and then power up the VISTA panel.

2. Within 1 minute of powering up the VISTA panel, simultaneously press and hold the # and * buttons on 
the keypad.

3. The keypad displays INSTALLER CODE. Enter the installer code (default is 4112), followed by 8 0 0.

4. Enter *193, then enter 1 0.

5. To save and exit programming, enter *99.

User Codes in the Ademco/Honeywell Panel

Because the communicator duplicates the panel’s user codes, existing user codes in the Ademco/
Honeywell panel, including master, must be added to the communicator. The DualCom must also have user 
2 as a master using the same user code as the host panel user 2. This is required to allow codes added 
via App/Browser to be sent to the host panel. Any new user codes added to the communicator from the 
Virtual Keypad App will be automatically entered in the Ademco/Honeywell panel. 

User codes from the Ademco/Honeywell panel that are designated as master or partition master should be 
configured as master codes in the communicator.

If the Ademco/Honeywell panel is armed/disarmed from a keypad, the communicator reports an opening/
closing message by user 0 to the central station.

When the communicator is armed by the Virtual Keypad App or VirtualKeypad.com, the Ademco/Honeywell 
panel is also armed and the communicator reports an opening message. If opening and closing reports are 
enabled in the Ademco/Honeywell panel, a duplicate message will also be sent to the central station.

Note: Communicators with Version 194 and higher do not require you to log in to the VISTA panel with a 
master code to manage user codes remotely.

STEP 4: CONFIGURE ECP SETTINGS
For the communicator to properly process data from the VISTA panel, keypad input must be set to ECP. You 
can perform this programming remotely with Dealer Admin or locally with a programming keypad.

Remote programming requires communicators with firmware Version 212 or higher. Local configuration 
requires communicators with firmware Version 202 or higher.

During configuration, refer to “Troubleshooting” for programming messages and troubleshooting steps.

Remotely (Dealer Admin)
Before programming, ensure the ECP panel’s IP address is set as default.

1. Go to Customers.

2. Find and select the system name.

3. Go to Full Programming > System Options.

4. In Keypad Input, select ECP.

5. In ECP Partition, enter the number of the partition where you want the communicator to operate.

6. Press Begin ECP Setup.

7. If the host panel is a VISTA 128, turn on VISTA 128.

8. Enter the host panel’s installer code in VISTA Installer Code.
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9. Press Begin.

10. After setup is complete, Dealer Admin automatically retrieves zones from the host panel. If you need to 
retrieve zones again later, open System Options and select Get Zones. 

Locally (Keypad)
To advance through the programming menu, press CMD. To go back, press the Back Arrow key. To enter a 
menu, press any select key or area. To select an option, press the select key or area under that option.

Before programming, ensure the ECP panel’s IP address is set as default.

1. Power up or reset the communicator.

2. At the communicator keypad, enter 6653 (PROG) and press CMD.

3. Advance to SYSTEM OPTIONS, then press any select key or area to enter the menu.

4. Advance to KYPD INPUT, then press any select key or area.

5. Select ECP by pressing the third select key or area under that option.

6. At ECP PARTN NBR, enter the number of the partition where you want the communicator to operate. 
Range is 1 - 8. Default is 1.

7. To save programming, advance to STOP and press any select key or area.

8. At the communicator keypad, enter 2313 (DIAG) and press CMD.

9. Advance to ECP SETUP and press any select key or area.

10. At ECP SETUP VISTA 128?: If the panel is a VISTA 128, select YES. Otherwise, select NO.

11. At INST CODE, enter the ECP panel installer code and press CMD.

12. After configuration is finished, the keypad advances to GET ZONES. Press any select key or area. 

As the communicator retrieves zones from the ECP panel, the number of zones is displayed and incremented 
as ZONE CT (zone count).
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Manually Configure Communication with the Ademco/Honeywell Panel

The following steps describe how to configure Ademco/Honeywell control panels to communicate with the 
communicator. Only use these steps if programming isn’t configured automatically with ECP SETUP.

1. Program Position * 54: Enter 0. This enables no signaling delay.

2. Program Position * 55: Enter 1. This enables communication to the communicator.

3. Program Position * 84: Enter 0. This disables CP01 and allows remote Arm Away.

4. Program Position * 193: Enter 1 0. This enables the DualCom ECP Bus address.

If the Ademco/Honeywell panel fails to communicate with the communicator, program Position * 29 to 
enable the long range radio on the Ademco/Honeywell panel.

Troubleshooting
Message Meaning Next Steps

PROGRAMMING The communicator is attempting to 
configure ECP panel programming 
settings for ECP Passthru.

Wait for the configuration attempt to complete. 
Afterward, a programming status message is 
displayed (success, fail, or busy).

PROGRAM SUCCESS The ECP panel has been successfully 
configured.

Finish configuration at GET ZONES.

PROGRAM FAIL The ECP panel could not be 
programmed. 

Check wiring connections and communication 
settings, then retry programming. 

BUS IS BUSY The ECP panel could not be 
programmed due to high ECP bus 
traffic.

Wait and retry programming or reduce traffic on the 
ECP bus, then retry programming.

Table 2: Programming Messages and Troubleshooting
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STEP 5: REMOTE PROGRAMMING
Starting with Remote Link™ Version 1.93, you can connect a customer’s Honeywell VISTA® panel with 
CellCom, DualCom, or iComSL Series communicators using Honeywell’s Compass® software and Remote 
Link. 

Set up Remote Link
The following instructions assume that you already have a basic communicator account added to your 
Remote Link accounts. To enable ECP Passthru for that account, complete the following steps.

1. Right-click Remote Link and select Run as administrator.

2. Double-click the communicator account to open it.

3. Go to Program > System Options.

4. To enable communication, go to Keypad input and select ECP. Press OK.

5. Go to File > Panel Information.

6. In Connection Information, enter the VISTA account number in Ecp Acct.

7. Press OK.

8. Go to ECP Passthru > ECP Start/Stop Server.

9. Minimize Remote Link.

6

7

8
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Add the VISTA Panel in Compass
1. Open Compass. 

2. In the lower right corner of the Customers page, select Add. The Customer Detail window opens.

3. In Subscriber Data, enter a Receiver number and Account number.

4. In the Panel Data section, select the VISTA panel model and revision number. 

5. In Network Device MAC Addr, enter FFFFFF. 

6. Press OK.

3

4
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Set Up Communication in Compass
1. In Customers, double-click the account that you created in the previous section. 

2. The Panel Editor opens. Go to Tools > Communications.

3. Go to File > Communication Settings.

4. Select TCPIP Port Settings.

5. To ensure that Compass uses a TCP/IP connection, select a TCP/IP port.

6. Press Add. 

7. Back in Communication Settings window, select Apply. 

8. Press OK.

4 78

5 6
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Configure TCP/IP Settings in Compass
1. In the lower left corner of the Compass Communication window, press Connect.

2. A dialog pops up to notify you that communication settings must be configured. Press OK.  

3. Select Enable TCP/IP. 

4. In the TCPIP Port dropdown, select the appropriate TCP/IP port. 

5. Ensure that the Network Device MAC Addr is FFFFFF.

6. In Connection Mode, select ECP.

7. Ensure that AlarmNet-i is selected.

8. Press Connect.
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REFERENCE
Virtual Keypad
Virtual Keypad enables users to manage their systems remotely, including arming, disarming, viewing zone 
status, bypassing zones, view history, manage users, and more.

To use Virtual Keypad for remote management, the configuration must meet the following conditions: 

• ECP Panels must be programmed as Stay/Away for remote arming and disarming (No Partitions).
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VISTA Panel Compatibility

Panel Type ECP Remote  
User Management

Remote  
Arming/Disarming

Remote  
Zone Status

Compatible with 
Compass

VISTA-10SE Rev 15 or higher No No No No

VISTA-10P Yes Yes Yes Yes Firmware version 
2.0 or higher

VISTA-15 Yes No No No No

VISTA-15P Yes Yes Yes Yes Firmware version 
5.2 or higher

VISTA-20SE Rev 12 or higher No No No No

VISTA-20P Yes Yes Yes Yes Firmware version 
5.2 or higher

VISTA-20PI Yes Yes Yes Yes Firmware version 
5.0 or higher

VISTA-21iP Yes Yes Yes Yes Yes 

VISTA-21iPLTE Yes Yes Yes Yes Yes

Note: Vista 32, 40, 50, 128, 250 are not compatible with ECP Virtual Keypad and eSuite.
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